[Live-devel] testOnDemandRTSPServer problem with two routers

=?gb2312?B?1tO588a9?= zhonggp at chinabizone.com
Mon Nov 15 16:01:56 PST 2004

Hi Ross,

I happened to meet some trouble these days.
My development enviroment is quit unususal.  There are two routers, say and, each of them could be my gateway. If testOnDemandRTSPServer was started up  in while my gateway was fixed to, I  just can not receive any audio or video data by using VLC. Howerver ,the debug output information in indicated that the two control channels( I mean RTCP and RTSP) had  been established .  

Of coure it works well when I set my gateway to

In my opinion, the cotrol channels were established indeed  via my gateway ,but the data channel perhaps not .The router( may send  a/v data directly to my PC rather than via my gateway.Therefor,  all the data packets will be dropped because my PC can only recognize the packet returned from its gatesway (, other packets  are treated as illegal.

If my suppose is right, then how to fix it ? Does it take effect to modify the source file merely ?

BTW, could a PC in a LAN  behind a route receive  the data streamed by testOnDemandRTSPServer  in another host in the internet? 
You can contact this URL: 
I will keep it for several days. Please let me know  whether or not your could receive it.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.live.com/pipermail/live-devel/attachments/20041115/bce04086/attachment.html

More information about the live-devel mailing list